HP Forums
[WP-34S] Troubleshoot internal USB Board - Printable Version

+- HP Forums (https://www.hpmuseum.org/forum)
+-- Forum: Not HP Calculators (/forum-7.html)
+--- Forum: Not quite HP Calculators - but related (/forum-8.html)
+--- Thread: [WP-34S] Troubleshoot internal USB Board (/thread-16199.html)

[WP-34S] Troubleshoot internal USB Board - Sanjeev Visvanatha - 01-19-2021 05:29 PM

Hello All !

I have a WP-34S that I added Harold's USB internal board. I cannot get the USB to transfer I/O between the emulator and the device. How do I go about troubleshooting this?

The USB seems to connect to my Win 10 machine, and I get a FTDI device on a virtual COM port in Device Manager. I also can see that the device is being powered from the USB port as I can remove batteries and operation is not interrupted.

Thank you in advance for any pointers.


RE: [WP-34S] Troubleshoot internal USB Board - John Galt - 01-21-2021 04:35 PM

Please refer to Appendix A in the WP 34s Owner's Manual. Describe the specific step at which you are getting stuck. Describe the exact error message(s) that appear, if any dialog boxes or errors are shown. Please use the same exact words that you see.

RE: [WP-34S] Troubleshoot internal USB Board - Sanjeev Visvanatha - 01-22-2021 12:26 AM

My computer is Windows 10, and I am running MySamba as Adminstrator.

My 34S was flashed with an older version of the firmware, and I was attempting to update it via the flashing procedure I have always used, namely HP cable with Prolific Serial Converter and MySamba. It has the USB board installed, but I could not get it flashing that way previously, so I use the HP cable instead.

I have the PDF Version of the WP-34S v3.3 Manual. In Appendix A, I follow all steps until step A9:

"A9. Now click "Send File" in the MySamBa window", at which point MySamba, after a few seconds says "unable to connect".

I have successfully flashed 3 other units today using the same procedure, with 100% success. These other 3 units do not have the USB board.

Batteries are measured at 3V each.

RE: [WP-34S] Troubleshoot internal USB Board - John Galt - 01-22-2021 12:44 AM

From my notes, the message "Error, Unable to connect" will occur if the calculator is not on, or if there is no response whatsoever from the calculator.

If the computer's USB interface is not working or if the Windows 10 "Com port" was not properly configured, the message would be "Error, could not connect to calculator" with those exact words and capitalization.

Your description leads me to believe the fault lies beyond your computer and is within the calculator itself. It is as though the calculator is not "on" because no response is being received. Perhaps for example the connections to Harald's board are not intact or are not going to the correct solder pads.

Here are some additional notes I archived long ago from this forum, with a calculator that may have become unresponsive for whatever reason:

1. Turn on the calculator (do not worry if it is unresponsive due to earlier flashing failures). Pressing ON ensures it's really "on".
2. Plug in in the programming cable into the calculator and plug the USB end into the computer
3. Set up MySamba to prepare to do the download (do not press [Send File])
4. Press and hold the calculator's [On] key. Do not release it.
5. Press and hold the programing cable's ERASE button
6. Press the RESET button inside the back cover of the calculator with a paper clip
7. Release the ERASE button
8. Release the calculator [On] button
9. Turn the calculator on (should not get any response)
10. Press the MySamba [Send File] button to send the flash image. After a few seconds you should see the transmit progress.
11. Disconnect the cable on both ends and exit MySamba
12. Press the reset button with a paper clip again
13. Press the calculator [On] button. It should come alive with the new flash image.

RE: [WP-34S] Troubleshoot internal USB Board - Sanjeev Visvanatha - 01-22-2021 01:02 AM

Thank you for the assistance. I have tried all methods of flashing I have read, including the additional one you last described. I will open it up and verify the connections to the USB board next.

RE: [WP-34S] Troubleshoot internal USB Board - Harald - 01-23-2021 09:35 PM

I never thought of a flash cable being plugged in when a USB board is installed. I will have to look into what can happen in this case. I would not rule out that the board could be damaged.
So if I get this correctly, you tried flashing via USB board first and had no success. Then you tried the cable and still had no success.
Is the calculator completely unresponsive or is it still running on the old firmware?

Has the board ever worked at all?

RE: [WP-34S] Troubleshoot internal USB Board - Sanjeev Visvanatha - 01-24-2021 03:31 AM

Hi Harald!

I had flashed it initially with the HP cable. This worked and I had the basic 34s firmware. Then I installed the USB board and wanted to flash it again with the USB board to get the IR/XTAL version. That did not work via USB, in spite of all the connections appearing correct and the computer recognizing the FTDI chip. So I flashed it again using the HP cable. This also worked, and IR printing and XTAL was working. Then about a week later, I decided to attempt I/O with the emulator via USB, and could not get that to work at all. I then tried flashing via USB using the instructions from the manual, and the calculator went into that "dead state", and hasn't recovered. The HP cable method does not work at all now. To answer your question, the USB has never worked.