HP Forums
Error executing command in hprime - Printable Version

+- HP Forums (https://www.hpmuseum.org/forum)
+-- Forum: HP Calculators (and very old HP Computers) (/forum-3.html)
+--- Forum: HP Prime (/forum-5.html)
+--- Thread: Error executing command in hprime (/thread-18394.html)

Error executing command in hprime - HebertPV - 05-21-2022 08:22 AM

Hello my name is Hebert PV, I like to program in PPL MODE on the HP PRIME, but with the latest updates I detected an error where when creating a program in PPL using a CAS command example:


LOCAL MAT, var_count;




The result in the finish will throw me 3

but when executing the program again, it will throw me a syntax error, so using several commands such as: inv, colDim, maxnorm, row etc.

I tried to solve these problems by creating an own function to count the rows or columns or find the maximum value of a matrix but this should not be the case, those commands worked normally before now since 2020 I detect that error.

I have been programming since 2016, I must make a note that this only happens when executing the code in the emulator since in the physical calculator it works normally.