HP Forums
Bug in ker(), solved - Printable Version

+- HP Forums (https://www.hpmuseum.org/forum)
+-- Forum: HP Calculators (and very old HP Computers) (/forum-3.html)
+--- Forum: HP Prime (/forum-5.html)
+--- Thread: Bug in ker(), solved (/thread-6121.html)

Bug in ker(), solved - Arno K - 04-23-2016 10:47 PM

Refreshing my mathematics I today came across the task to compute the kernel of a linear function which was not too hard to do myself but then I thought to give it a try with the pc-emulator, version 10077 expecting something like [[0,0,0]] as f(x,y,z)=(3*x,x-y,2*x+y+z) obviously is bijective, but I got [[]],so I took my android device with the old version of the cas, 8151, it provided the same answer, then tried my physical Prime, which I successfullly had updated, too, and got the same result, finally I tried XCAS 1.2.2-33, the same. Not that big to deal with, but should be corrected some day.

RE: Bug in ker() - parisse - 04-24-2016 06:04 AM

ker returns a basis of the kernel, if the kernel is of dim 0, the basis is empty.

RE: Bug in ker() - Arno K - 04-24-2016 08:29 AM

Ok, this explains the empty matrix.
Thank you