Post Reply 
Prime - different hardware, Connectivity causes Prime HW verA Reset
01-05-2022, 09:00 PM (This post was last modified: 01-05-2022 09:42 PM by TomC.)
Post: #1
Prime - different hardware, Connectivity causes Prime HW verA Reset
Hello:

I've got two Primes which I'd just updated the OS today:

1. Software Version 2.1.14603 (2021 12 02)
Hardware Version A
CAS Version 1.5.0
Serial Number: 4CY34xxxxV
Operating System: V0.050.640

2. Software Version 2.1.14603 (2021 12 02)
Hardware Version D
CAS Version 1.5.0
Serial Number: 9CJ92xxxS9
Operating System: V2.060.650

I had purchase #1 long ago - probably shortly after the Prime Release.

I purchased #2 not too long ago (2018?).

#2 works just fine.

[Running Connectivity Kit on Win10, Connectivity Kit Build 2.1.14596 (2021 10 1).

#1 seems to work until...

I connect the connectivity kit. The connectivity starts up, connects to the Prime and shows its name in the window.
When I click on the calculator name in the window, the menu below appears for about a second, then the calculator power cycles.

Should I 'upgrade' this older hardware with a previous OS version?
[My apologies if this has been touched on before!]

Regards and Happy New Year,
TomC
Find all posts by this user
Quote this message in a reply
01-05-2022, 11:29 PM
Post: #2
RE: Prime - different hardware, Connectivity causes Prime HW verA Reset
Good afternoon!

I’ve just tried this sort of thing with a revision A Prime here, probably just a little bit older than yours, and didn’t experience the described issue. (The calculator and Connectivity Kit continued to operate as expected.)

I tried with both revision 14592 and revision 14596 of the 64-bit version of the Connectivity Kit on a 64-bit Windows 10 PC. (Are you using 32-bit versions of either?)

If you have backed up all of the data on your older Prime, it might be informative to try repeating the steps with it after it’s been wiped clean (perhaps some data on the calculator is affecting operations).
Find all posts by this user
Quote this message in a reply
01-06-2022, 11:53 AM (This post was last modified: 01-06-2022 12:03 PM by TomC.)
Post: #3
RE: Prime - different hardware, Connectivity causes Prime HW verA Reset
Thank you for the prompt reply.

I had reflashed the unit several times - same results. How do I totally reset the machine?

Where would I find older flash images?

A couple clues - the 'Home Settings' has only 3 pages whereas my newer hardware has 4 pages.
The setup screens appear a bit different too!??
Also, when I go to the 'Program Catalog', there is a Function App there (that I do not believe I put there and it does not go away)
Also, the 'Data Streamer' app is greyed out.
Also, Page 3 of the Home Setup is an 'Exam mode' screen.

I've tried this from two different Win10 machines - same results (not sure if I'm running the 32 or 64 bit versions of the connectivity kit).

Regards,
TomC

(01-05-2022 11:29 PM)jte Wrote:  Good afternoon!

I’ve just tried this sort of thing with a revision A Prime here, probably just a little bit older than yours, and didn’t experience the described issue. (The calculator and Connectivity Kit continued to operate as expected.)

I tried with both revision 14592 and revision 14596 of the 64-bit version of the Connectivity Kit on a 64-bit Windows 10 PC. (Are you using 32-bit versions of either?)

If you have backed up all of the data on your older Prime, it might be informative to try repeating the steps with it after it’s been wiped clean (perhaps some data on the calculator is affecting operations).
Find all posts by this user
Quote this message in a reply
01-07-2022, 03:15 AM
Post: #4
RE: Prime - different hardware, Connectivity causes Prime HW verA Reset
(01-06-2022 11:53 AM)TomC Wrote:  Thank you for the prompt reply.

You’re most welcome!

(01-06-2022 11:53 AM)TomC Wrote:  I had reflashed the unit several times - same results. How do I totally reset the machine?

Maybe the next step is to reset all the apps. To do that, go to the Application Library screen and then press shift-Esc (and confirm that you want to “delete” all apps — this will remove any custom apps added, any apps customized, etc.; blank system apps will be present in the Application Library after shift-Esc).

(01-06-2022 11:53 AM)TomC Wrote:  Where would I find older flash images?

With FileZilla, I see older firmware images in /pub/calculators/Prime at ftp.hp.com.

(01-06-2022 11:53 AM)TomC Wrote:  A couple clues - the ‘Home Settings’ has only 3 pages whereas my newer hardware has 4 pages.
The setup screens appear a bit different too!??

Yes, this is normal. My revision A Prime is the same; it doesn’t have wireless capabilities. (Wireless Network Properties are configured in page 4.)

(01-06-2022 11:53 AM)TomC Wrote:  Also, when I go to the ‘Program Catalog’, there is a Function App there (that I do not believe I put there and it does not go away)

The Program Catalog uses one slot for the program for the active app. (Which, it seems, was the Function app when you went to the Program Catalog. You should see a different program there if a different app is active. I do think some changes to the UI should be made here, to make it a bit more obvious what is going on to those starting out with the Prime.) If you haven’t started a program yet for an app, it will still occupy a slot in the Program Catalog when the app is active (tapping Edit should then bring up an a source code editor without any code yet present).

(01-06-2022 11:53 AM)TomC Wrote:  Also, the ‘Data Streamer’ app is greyed out.

The Data Streamer is also greyed out on my revision A Prime.

(01-06-2022 11:53 AM)TomC Wrote:  Also, Page 3 of the Home Setup is an ‘Exam mode’ screen.

This should be the case on both of your Primes.

(01-06-2022 11:53 AM)TomC Wrote:  I’ve tried this from two different Win10 machines - same results (not sure if I’m running the 32 or 64 bit versions of the connectivity kit).

Would you happen to know if your Win10 machines are running 32-bit or 64-bit Windows?
Find all posts by this user
Quote this message in a reply
01-08-2022, 06:39 PM
Post: #5
RE: Prime - different hardware, Connectivity causes Prime HW verA Reset
jte:

Thank you again for your helpful and thorough responses.

So, It appears that my old hardware machine is working properly.

I am running 64 bit win10.

I have noticed, by the way, that the connectivity kit pauses often and windows shows 'Not responding' in the title bar. Waiting a few (sometimes 10!) seconds and it continues properly

Regards,
TomC
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: