Post Reply 
Wp34s firmware update problem
08-19-2018, 05:19 PM
Post: #1
Wp34s firmware update problem
Hello, after a long time (years) I got curious and decided to upgrade my wp34s, which was still at the latest "official" 2015 version. But what do they say about curiosity? Either I forgot how to do it, or something changed, anyway I can't seem to flash it, and I apparently bricked my calculator.
I'm using Linux, so I use the multi-platform tool.
I connected the cable, then I prepared the calculator by On+D then On+S+S. The screen went off, I pressed On. As expected, I got nothing on the display.
But when I try to run the flash tool... I get a "can't connect" error. I also tried the "Reset + On" trick, still no joy. The command I ran is

sudo ./wp34sflashcmd calc_full.bin /dev/ttyUSB1

And yes, I checked that ttyUSB1 is the correct port for the adapter.
Any hints on what to check next? The calculator was working very well, but I can't rule out some failure on the cable, though the pogo pins seem to be in excellent shape...

Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
Wp34s firmware update problem - Cristian Arezzini - 08-19-2018 05:19 PM

User(s) browsing this thread: 1 Guest(s)