Post Reply 
[solved] Connectivity Kit (Mac) cannot see new Prime G2
09-26-2018, 02:43 PM (This post was last modified: 09-27-2018 11:20 PM by cdmackay.)
Post: #1
[solved] Connectivity Kit (Mac) cannot see new Prime G2
hi, would appreciate any help here, please.

My problem is that the Connectivity Kit on my Macbook cannot see my new Prime G2, when connected via USB.

I'm new to these waters; I've been a Casio-er for decades, currently using the CG50 with GIAC CAS plug-in, and the CP400.

Had been interested in trying the Prime, so I bought the new G2 model yesterday. Seems fantastic so far.

I thought it would be fun to try the Connectivity Kit, and also to put the new Beta firmware on the calculator.

I'm using a 2018 MacBook Pro, running MacOS 10.13.6.

It has Thunderbolt 3 (only). This provides USB 3 busses via USB-C sockets. Because it only has two of those TB3 ports, and they are also needed for power and display, I'm using a Thunderbolt 3 dock, which itself also provides USB 3 busses, to which I'm connecting the Prime.

I put the Prime G2 into Update mode with Reset pin and Symb, and connect via a USB cable.

The calculator knows it has been connected to something, since the on-screen instructions disappear (and then reappear if I unplug the cable).

The MBP can see the Prime, if I check the USB devices via System Information.

I then start the Connectivity Kit, but it doesn't see any calculators. [It does see the emulator, if I start that up on the laptop, but it doesn't see the USB-connected Prime]

The Prime G2 came with firmware 2.0.0.13725 (2018 04 26).

Am I doing something obviously wrong, or missing something important? What can I do to get more debugging info?


Here's some things I've tried:

• multiple known-good USB A – microB cables, including the one supplied with the Prime

• connected the cable both to the Thunderbolt 3 dock's USB 3 port, and also to that dock via an intervening downstream USB 2.0 hub, and also a downstream USB 3.0 hub. [I can't connect directly to the laptop since I don't have a USB-C to micro-B cable, and in any case both ports on the laptop are permanently in use]

• two versions of Connectivity Kit: 20180706 & Beta 20180917 [Do I need a version that matches the 20180426 on my Prime?]

• various combinations of starting the Connectivity Kit before and after connecting the Prime

• rebooting the laptop


any suggestions please, on what I might be missing, or how to collect more debug data?

thanks very much indeed.

===

edit: hmm, well all is now well.

I did various things, but I think reinstalling the CK from scratch is what fixed it.

Cambridge, UK
41CL/DM41X 12/15C/16C DM15/16 17B/II/II+ 28S 42S/DM42 32SII 48GX 50g 35s WP34S PrimeG2 WP43S/pilot
Casio, Rockwell 18R
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
[solved] Connectivity Kit (Mac) cannot see new Prime G2 - cdmackay - 09-26-2018 02:43 PM



User(s) browsing this thread: