Post Reply 
Emulator program whitespace
12-19-2013, 09:58 PM
Post: #1
Emulator program whitespace
I encountered an anomoly with the Prime emulator that after I edited a couple of emulator programs and then edited them back to their original state, they would not run in the emulator, but would run in the physical calculator. Examining the emulator and calculator programs in the connectivity kit, showed no differences in, at least, the text in the programs.

The emulator programs showed no errors when the programs were checked. When I tried to run them, it would popup an error "unmatch control word", when it tried to call a subroutine. I experimented with it, and it appeared it was not even seeing the subroutine it was attempting to call, even though the subroutine was there.

I erased the contents of the emulator file programs in the connectivity kit, and then copied the physical calculator files directly from the calculator to the connectivity kit emulator file window. They still wouldn't run.

Reading through the Prime threads, there was a thread "Invalid Input during local variable declaring", and Han had commented about whitespace being different.

I went back to the emulator files and started checking the whitespace. I eventually found that what ever I had done in the original editing of the file, had added an extra,what appeared to be, a blank line after the END; like this:
BEGIN
Program lines...
END;
(blank line)

When I removed the "blank line", I was able to get the programs to run again in the emulator. I attempted to recreate the anomoly, but have been unable to do so, either in the emulator or physical calculator.
rcf
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Emulator program whitespace - Bob Frazee - 12-19-2013 09:58 PM
RE: Emulator program whitespace - Han - 12-24-2013, 04:24 AM
RE: Emulator program whitespace - eried - 12-24-2013, 07:01 AM



User(s) browsing this thread: