Post Reply 
New HP 28S, strange behaviour
03-21-2016, 07:44 PM
Post: #1
New HP 28S, strange behaviour
Hi all!

Long time lurker, first time poster here!

I finally jumped ahead sadly because I just receive a nice (perfect physical condition, perfect battery door...) made in USA 28S, and if the self-test run fine and all basic calculations are ok, I can't access to any menu or advanced functions.

When I received it and tried to print something on my 82240A printer (the first thing I tried since the printer was laying on my desk and powered on, lol, just used it to print a grocery list with my 19B), it displayed the message "out of memory". I answered yes to all questions before trying to reset memory (I was curious of what previous owner could have programmed), but all I got was the continuous display of the appointment/busy calc.

Now when I try to do anything that is not on the numeric keybord, the calculators hangs and displays the busy sign. I can do the self-test ever and ever (ok 28S), reset memory, but no improvement. Also when it hangs the pile displays


(this is my first 28S, don't know if normal)

I can access catalog and units (mem argument when used through catalog returns 32K memory, and the few thing I tried through catalog seem to work ok), but anything else just displays the busy signal and I have to do a soft reset (on + C) to get it back to pseudo-normal.

Do you know what could be wrong with it? I opened various 18/19B in the past with various rate of success, but since I payed a nice sum for this "cosmetically perfect" 28S, I'd rather return it to seller if it is not usable...

I'll try to let is without batteries for a while, hoping for improvement Smile

Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
New HP 28S, strange behaviour - Lithium - 03-21-2016 07:44 PM
RE: New HP 28S, strange behaviour - Jlouis - 03-21-2016, 08:47 PM
RE: New HP 28S, strange behaviour - Marcio - 03-21-2016, 08:52 PM

User(s) browsing this thread: 1 Guest(s)