Post Reply 
[solved] COLLECT bug? (10637)
11-20-2016, 07:26 AM (This post was last modified: 11-23-2016 02:15 AM by tastyelectron.)
Post: #1
[solved] COLLECT bug? (10637)
Hello all, I'm new to the forum and HP calculators in general.

Working within CAS on firmware (10637), I believe that I've found some repeatable incorrect results from collect():
collect((a*b+a*c)/(a*d+a*e+d*e), a)

Numeric substitution confirms the invalid result:
subst((a*b+a*c)/(a*d+a*e+d*e), {a=2,b=3,c=4,d=5,e=6})
subst((a*(b+c))/(e+d), {a=2,b=3,c=4,d=5,e=6})

I'm content with collect()'s work in the numerator but for nearly half of my uses it appears to be chewing up denominators and returning only simplified portions of them, casting doubt over the work of this function and the underlying CAS.

Perhaps I am expecting something this function wasn't designed for, but the Help appears to describe this function as returning an equivalent representation of the input, collected with respect to Var.

Thanks all
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
[solved] COLLECT bug? (10637) - tastyelectron - 11-20-2016 07:26 AM
RE: COLLECT bug? (10637) - DrD - 11-20-2016, 11:21 AM
RE: COLLECT bug? (10637) - tastyelectron - 11-20-2016, 06:45 PM
RE: COLLECT bug? (10637) - JMB - 11-20-2016, 11:23 AM
RE: COLLECT bug? (10637) - DrD - 11-20-2016, 11:49 AM
RE: COLLECT bug? (10637) - parisse - 11-21-2016, 07:29 PM
RE: COLLECT bug? (10637) - John P - 11-21-2016, 07:40 PM
RE: COLLECT bug? (10637) - tastyelectron - 11-23-2016, 02:13 AM

User(s) browsing this thread: 1 Guest(s)