Post Reply 
HP 71B CAT$ Problem
02-12-2017, 06:04 PM (This post was last modified: 02-13-2017 01:56 AM by Paul Berger (Canada).)
Post: #4
RE: HP 71B CAT$ Problem
Never mind it seems the odd behaviour is caused by Linkplus, I tried a different PC with a HPIL adapter and I get a different result. On this second one it goes through the directory correctly but it does not print out the total and turns off the 71B when it is done... very strange.

Edit.... Well maybe not so strange after all. One of the devices that Linkplus emulates is a printer, which it of course redirects to the PCs printer device, and if you PRINT something when there is no printer attached bad things happen, they even warn you about that in the manual. Well when I wrote the program I used PRINT instead of DISP to display the total and had no printer attached. It finally occurred me when I got home this evening that it might be trying to print something, so I hooked up a printer and sure enough it printed the total it was then that it finally clicked that I had used PRINT instead of DISP. It would have been nice if they allowed you to turn off the printer emulation.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
HP 71B CAT$ Problem - Paul Berger (Canada) - 02-12-2017, 03:46 AM
RE: HP 71B CAT$ Problem - J-F Garnier - 02-12-2017, 09:02 AM
RE: HP 71B CAT$ Problem - Paul Berger (Canada) - 02-12-2017 06:04 PM
RE: HP 71B CAT$ Problem - Joe Horn - 02-13-2017, 01:47 PM



User(s) browsing this thread: