Post Reply 
Texas Instruments TI59 weird card problems
10-26-2021, 02:05 AM
Post: #1
Texas Instruments TI59 weird card problems
For quite a time, I've been looking for a TI 59 to play, so when I saw one complete kit at a local flea market, I couldn't resist. After taking it home I noticed that was indeed a very nice model. The old batteries had already been removed and there was no corrosion anywhere. Apart from the normal amount of dust you'd expect for something like this, everything was in place. So I rebuilt the battery pack and gave it a clean with a moisted towellette. After making sure there was proper voltage at the battery terminals, I placed the pack and voila! It turned on right away. All the keys worked, all the operations gave the correct results, and even I could read some of the cards written by the previous owner. Ran the diagnostic card and there it was: diplay full of eights!

So I decided to take a deeper look into the other blank cards included, so I could retrieve any data stored on them. Turned out that whoever was the previous owner took great care of the device and/or it had very little use since there where only 4 custom written programs, and most of the pre-written cards looked intact. Wrote two test cards (a program counting from 1 to 9 and another one counting from 9 to 1) and read them with no problem. Tested the ROM module with success. That when I decided to place the key-code mat over the keys when, by magic, I sticked one of my previously written cards to the side but it refused to read. Not even spin the motor! I noticed that the display, when a card was inserted, a "C" on the left side as well as for a fast-blinking "8" on the right side showed up on the screen. If the card was removed (manually because there was no motor activity) then the "C" went away; the number "8" stayed in place but this time with a slower blinking pattern (similar to an error condition). You could press CLR to reset the operation weirder things happened: Let's say you were to do 25+3 you'd get 28, but if you wanted to do sin90 then you'll end up with a "0". Additionally, if you wanted to access the program mode by pressing LRN, at first you'll get garbage symbols; if you tried again, instead of "000 00" pattern, it showed "000000".

At first I thought it was all due to a misconnection between contacts inside the card reader mechanism. I downloaded the service manual and read the of that part. To my surprise when I got to open the case, everything seemed allright!? No corrosion, no acid, anything. Tested several times those contacts but everything worked accordingly. Tested the flex connectors in seek of shorts/misconnections but all ok. Lastly ran some voltage over the motor (2V) and it was ok!

After scratshing my head during 2 hours, I came to the conclusion that I don't know what is going on. My clues point where nothing makes sense. How it was working nice, but all of a sudden it collapsed?

If anyone has a similar experience I would really appreciate your help.

Sincerely, voltaage.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
Texas Instruments TI59 weird card problems - voltaage - 10-26-2021 02:05 AM

User(s) browsing this thread: 1 Guest(s)