Post Reply 
Complex solve BUG FW 2016 04 14 (10077)
05-19-2016, 06:22 PM (This post was last modified: 05-19-2016 06:43 PM by Maro.)
Post: #1
Complex solve BUG FW 2016 04 14 (10077)
I have to solve the following equation for variable x:

eqn: (C1/C2)-(C3/C2)*C4*(1-i*tan(acos(C5)))/(3*conj(x)) - x = 0

C1 to C5 are constant numbers, either real or complex values.


With these parameters the equation has two solutions (e.g. solved with Matlab)

After updating to FW 10077 it is no longer possible to solve this equation using "cSolve" or "solve" in CAS environment or in program. I have tried with various settings, but no success. The result is always: []

This is especially annoying since there was absolutely no problem to solve the equation before updating the firmware. I need to solve this equation with various parameters C1 to C5 within a very large program that took me very long time of development. With this problem I can no longer use the software (Grrrr). Before the firmware update everything was fine and Prime solutions always were in line with Matlab etc.

Interestingly, when C2 is real and not complex, it seems to work, at least in some cases.

cSolve and solve have obviously a bug with the new firmware. Any idea??

Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
Complex solve BUG FW 2016 04 14 (10077) - Maro - 05-19-2016 06:22 PM

User(s) browsing this thread: 1 Guest(s)