Post Reply 
HP 71B CAT$ Problem
02-12-2017, 04:59 PM
Post: #3
RE: HP 71B CAT$ Problem
(02-12-2017 09:02 AM)J-F Garnier Wrote:  It may be related to the end-of-directory bug (on both 1A and 1B ROM versions), an old bug that I recently described in detail on my HP71 bug page.
But I can't reproduce your problem (on my emu71 emulator, not with a real HP9114). Even with a directory full (and so a corrupted first file), CAT$ after the last file correctly returns a null string.

If you could make a disk image, I would like to investigate. I'm still interested in all HP71 new-old-bugs !


Well the diskette has been hit by the end of directory bug, and it would seem that the end of directory marker is what it is failing on, but I guess there is a chance I may have tried to read past it too. I ran my program on a diskette that does not have a full directory and the same thing happened when it got to the end. I will play with it a little more to see if I can get a better idea of the cause.

Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
HP 71B CAT$ Problem - Paul Berger (Canada) - 02-12-2017, 03:46 AM
RE: HP 71B CAT$ Problem - J-F Garnier - 02-12-2017, 09:02 AM
RE: HP 71B CAT$ Problem - Paul Berger (Canada) - 02-12-2017 04:59 PM
RE: HP 71B CAT$ Problem - Joe Horn - 02-13-2017, 01:47 PM

User(s) browsing this thread: 1 Guest(s)