Post Reply 
newRPL - build 1255 released! [updated to 1299]
05-27-2019, 09:10 PM
Post: #453
RE: newRPL - build 1255 released! [official and unofficial]
(05-27-2019 08:08 PM)JoJo1973 Wrote:  I've not been able to operate a USB transfer with my HP50g: that's the procedure I followed (firmware 1255 on the calc, firmware 1255 on the emulator)

1) I start the emulator and plug the calc: the transfer indicator lights up and USBSTATUS returns #3h, without need to type USBON
2) "Hardware/USB Connections" on the emulator: the calc is recognized, appears in the list and the "RX" indicator on the emulator's screen flashes.
3) Selecting the calc and pressing OK estabilishes the connection: USBSTATUS returns #0h
4) I type USBON on the emulator, the indicator lights up and USBSTATUS returns #3h
5) I type 30 USBRECV on the emulator and try to USBSEND an object: nothing happens and sometimes the emulator locks and I need to kill it. Other times the transfer silently fails.
6) Sending an object from the emulator to the calc using the reverse procedure fails either.
7) "Hardware/Remote USBARCHIVE to file" brings a dialog box to choose where to save the backup, but then fails: an "USB communications error" pops up, "USBAUTORCV error: Received invalid data" on the emulator and (not all the times) "~INVALID~" object on the calc.

Forget about USBSTATUS and USBON/OFF, none of that is needed.
The procedure should be:
Run the emulator and plug the calc in any order. Go to the USB connections dialog, the device should show the version in the list, if it does it's communicating well, just hit OK.
At this point connection is established and you can use all the menus and commands to send/receive. Type 1 USBSEND and it should instantly go to the other end.

Now, you seem to be having real issues: The received invalid data means the CRC checks are failing. Try a different port, different cable, etc. If you have a hub, try connecting it directly to the PC to make sure it's not a hardware issue. The strange thing is that it is doing the initial handshake well if it's showing the version in the list. To get the version, it's actually sending a program to the calculator that does VERSION and sends one of the strings with USBSEND, so if that works you do have a proper connection.

What version of Windows are you using? I used a library that's supposed to work from Windows 7 and up, but I only tested on Windows 10.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: newRPL - build 1001 released! - pier4r - 12-16-2017, 08:03 AM
newRPL - on Hp 39gs - Martin Hepperle - 06-05-2019, 06:51 AM
RE: newRPL - build 1001 released! - pier4r - 12-23-2017, 10:16 AM
RE: newRPL - build 1001 released! - pier4r - 01-01-2018, 09:42 AM
t - Claudio L. - 01-01-2018, 03:06 PM
RE: newRPL - build 1001 released! - pier4r - 01-01-2018, 03:41 PM
RE: newRPL - build 1001 released! - pier4r - 01-02-2018, 04:54 PM
RE: newRPL - build 1001 released! - pier4r - 01-02-2018, 06:58 PM
newRPL - brickviking - 10-05-2018, 06:01 AM
RE: newRPL - build 1255 released! [official and unofficial] - Claudio L. - 05-27-2019 09:10 PM
How to participate? - erazor - 12-13-2019, 07:12 AM



User(s) browsing this thread: