Post Reply 
newRPL - build 1255 released! [updated to 1299]
05-29-2019, 07:08 AM
Post: #458
RE: newRPL - build 1255 released! [official and unofficial]
(05-28-2019 10:41 PM)Claudio L. Wrote:  
(05-27-2019 10:03 PM)JoJo1973 Wrote:  Mixed progress:

First of all, I'm using Windows 10 and I never get a #7h when I press OK, neither on the calc nor the emulator.

Stuck with #3h, I get to transfer back and forth the emulator and the calc doing USBSEND on the sender and leaving unattended the receiver. Sometimes the transfer fails.

My apologies, looking at the source it seems at some point I replaced the bit from "connection with newRPL Desktop established" to "data is available for read". At the time it made sense that you are connected the moment you hit OK, so it becomes more or less useless to know that, #3h is good once connection is established. #7h is for programs to detect if there's data available when they disable auto-receive (via flag) and periodically check if there's some data ready to be picked up.

(05-27-2019 10:03 PM)JoJo1973 Wrote:  If I do USBSEND and 30 USBRECV on the receiver, the transfer never succeeds. Usually the receiver hangs and has to be reset/killed.
Arghhh... it seems in the rush to publish I forgot to backport the latest changes from USBAUTORCV to USBRECV. Good catch.

(05-27-2019 10:03 PM)JoJo1973 Wrote:  30 USBRESTORE/USBARCHIVE works perfectly, but using the Hardware menu fails always.

I tried various cables and ports on my laptop and always get the same results.

I confirmed your observations, USBRESTORE/ARCHIVE from the menu has some kind of race condition, depending on load my PC fails or not (works fine for the most part, but I was able to make it fail consistently under load). It seems the transfer takes place but the final confirmation fails to arrive (and without confirmation it reports it like an error). The calculator restarted every time and my directories were there (during RESTORE, after totally clearing the memory). I'll have to investigate further. The simulator doesn't seem to have that problem, as you noted.

As a workaround for the time being, backing up to the simulator and then using Save As... from the menu works the same. The file format is identical, the same file saved by the simulator can be sent via USBRESTORE to the calc directly (it mostly worked despite the error message). It can also be copied to an SD card to use SDRESTORE, or first open the file in the simulator and then send it to the calc. It's actually quite flexible.

That's great to know! In the meanwhile I can happily live with manual USBRESTORE/USBARCHIVE, which is really useful.
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: newRPL - build 1001 released! - pier4r - 12-16-2017, 08:03 AM
newRPL - on Hp 39gs - Martin Hepperle - 06-05-2019, 06:51 AM
RE: newRPL - build 1001 released! - pier4r - 12-23-2017, 10:16 AM
RE: newRPL - build 1001 released! - pier4r - 01-01-2018, 09:42 AM
t - Claudio L. - 01-01-2018, 03:06 PM
RE: newRPL - build 1001 released! - pier4r - 01-01-2018, 03:41 PM
RE: newRPL - build 1001 released! - pier4r - 01-02-2018, 04:54 PM
RE: newRPL - build 1001 released! - pier4r - 01-02-2018, 06:58 PM
newRPL - brickviking - 10-05-2018, 06:01 AM
RE: newRPL - build 1255 released! [official and unofficial] - JoJo1973 - 05-29-2019 07:08 AM
How to participate? - erazor - 12-13-2019, 07:12 AM

User(s) browsing this thread: