Post Reply 
wrong result using simplify()
06-20-2022, 02:25 PM
Post: #1
wrong result using simplify()
Hello forum

I'm playing around with my new HP Prime G2.
Trying to duplicate the inputs of a you tube video I entered in CAS: simplify(x+x+2y+x-y-x)

I got as result x+x+2.*y-y-x (with this strange decimal behind the 2), there's no simplification!
The guy in the video gets perfectly 2*x+y as expected.

What I'm doing wrong, whats going on?

In addition I did several complex things on it as areas between graphs and everything seems to be working fine there.

Any ideas out there - thanks very much.
Adrian
Find all posts by this user
Quote this message in a reply
06-20-2022, 09:40 PM
Post: #2
RE: wrong result using simplify()
Seems to be a matter of the settings for CAS. Go to <Settings> (for CAS of course) and choose <Minimum> as the option for 'Simplify' that should do it. BTW best is to avoid any implicit operations like '2y' instead of '2*y'

HTH Günter
Find all posts by this user
Quote this message in a reply
06-20-2022, 09:49 PM
Post: #3
RE: wrong result using simplify()
The decimal point MIGHT indicate that your CAS is set to Approx mode. Press Shift CAS [Settings], then make sure the Exact box has a checkmark.

<0|ɸ|0>
-Joe-
Visit this user's website Find all posts by this user
Quote this message in a reply
06-21-2022, 02:44 PM
Post: #4
RE: wrong result using simplify()
(06-20-2022 09:40 PM)Guenter Schink Wrote:  Seems to be a matter of the settings for CAS. Go to <Settings> (for CAS of course) and choose <Minimum> as the option for 'Simplify' that should do it. BTW best is to avoid any implicit operations like '2y' instead of '2*y'

HTH Günter

Dear Guenter

Thanks for your hint, but I had it already on minimum. But Joes hint with the tickbox of "genau" solved my problem.

Regards
Adrian
Find all posts by this user
Quote this message in a reply
06-21-2022, 02:45 PM
Post: #5
RE: wrong result using simplify()
(06-20-2022 09:49 PM)Joe Horn Wrote:  The decimal point MIGHT indicate that your CAS is set to Approx mode. Press Shift CAS [Settings], then make sure the Exact box has a checkmark.

Thanks this was the problem!
Regards
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: