Post Reply 
Solver Issue - how to view equations and backup
07-31-2022, 10:22 AM
Post: #1
Solver Issue - how to view equations and backup
Hi everyone

I have an issue with using the solver. On the calculator itself, I have cloned the Solver app (Say Solver and Solver 2) and on each one I have created different equations set.

The issue is that when i connect the HP Prime (I have a G1) to the connectivity kit, the connectivity kit will not see the equations that i have created on the calculator, and also the solver2 that i have created change to the blue icon (the functions app) on the connectivity kit (while it remains the orange colour on the calculator). No equations are visible. This happens regardless of how many times i deleted the solver apps and recreated.

This is how i do it on the calculator just to retrace my steps:
1. select the solver app icon.
2. press the "save" button.
3. Type a new name to the "name" field and ensure that the base app is "Solve".
The app is created on the calculator.
Then I launch it and type the equations into E1, E2, E3, etc.

But on the connectivity kit I can see the calculator fine - and can see the solve2 but it now become blue in icon.

How do i backup whatever equations i have created on the prime and how do i stop connectivity kit from changing this to blue function icon?

I have included a screenshot for reference.

Thanks


Attached File(s) Thumbnail(s)
   
Find all posts by this user
Quote this message in a reply
08-09-2022, 07:23 PM
Post: #2
RE: Solver Issue - how to view equations and backup
Hi Ken!

Including some screenshots is nice — they certainly help us see what you’re seeing.

Some additional information that could help is knowing which versions of the software you are using, on both the Prime and the PC.

For the Prime, version information is available in the Help system (to get the version information showing onscreen, press Help, then tap on Tree, go up to the top of the help tree and open “About HP Prime”); on the Windows version of the Connectivity Kit, version information is shown in the “About HP Connectivity Kit” window (which can be brought up by choosing “About HP Connectivity Kit” from the Help menu).
Find all posts by this user
Quote this message in a reply
08-10-2022, 03:36 PM
Post: #3
RE: Solver Issue - how to view equations and backup
(08-09-2022 07:23 PM)jte Wrote:  Hi Ken!

Including some screenshots is nice — they certainly help us see what you’re seeing.

Some additional information that could help is knowing which versions of the software you are using, on both the Prime and the PC.

For the Prime, version information is available in the Help system (to get the version information showing onscreen, press Help, then tap on Tree, go up to the top of the help tree and open “About HP Prime”); on the Windows version of the Connectivity Kit, version information is shown in the “About HP Connectivity Kit” window (which can be brought up by choosing “About HP Connectivity Kit” from the Help menu).

Hi jte, I am using HP Prime G1 (hardware version A) with software v2.1.14425 (2020 01 16). The Connectivity kit is v2.1.14596 (2021 10 1).

What could be happening with my solver issues?
Find all posts by this user
Quote this message in a reply
08-13-2022, 12:07 AM (This post was last modified: 08-13-2022 12:08 AM by jte.)
Post: #4
RE: Solver Issue - how to view equations and backup
(08-10-2022 03:36 PM)KenHag Wrote:  
(08-09-2022 07:23 PM)jte Wrote:  Hi Ken!

Including some screenshots is nice — they certainly help us see what you’re seeing.

Some additional information that could help is knowing which versions of the software you are using, on both the Prime and the PC.

For the Prime, version information is available in the Help system (to get the version information showing onscreen, press Help, then tap on Tree, go up to the top of the help tree and open “About HP Prime”); on the Windows version of the Connectivity Kit, version information is shown in the “About HP Connectivity Kit” window (which can be brought up by choosing “About HP Connectivity Kit” from the Help menu).

Hi jte, I am using HP Prime G1 (hardware version A) with software v2.1.14425 (2020 01 16). The Connectivity kit is v2.1.14596 (2021 10 1).

What could be happening with my solver issues?

Thanks for the additional information. I’ve just entered a couple of simple equations into the Solve app on a G1 and then tried to look at them with the Connectivity Kit. I met with success…

I tried the following combinations of revisions:
Code:
G1 Prime   Connectivity Kit
 r14622     r14592
 r14425     r14592
 r14425     r14596
(The revision being the number after 2.1 in the version information.)

I tried both adding definitions to the Solve app itself and a saved copy (a clone) of it.
  • Does the issue you’re experiencing happen even after resetting the Solve app and adding just a single simple equation to it?
  • Can you view definitions in other apps (using the Connectivity Kit)? (Such as the Function app.)
Find all posts by this user
Quote this message in a reply
08-14-2022, 06:49 AM
Post: #5
RE: Solver Issue - how to view equations and backup
(08-13-2022 12:07 AM)jte Wrote:  
(08-10-2022 03:36 PM)KenHag Wrote:  Hi jte, I am using HP Prime G1 (hardware version A) with software v2.1.14425 (2020 01 16). The Connectivity kit is v2.1.14596 (2021 10 1).

What could be happening with my solver issues?

Thanks for the additional information. I’ve just entered a couple of simple equations into the Solve app on a G1 and then tried to look at them with the Connectivity Kit. I met with success…

I tried the following combinations of revisions:
Code:
G1 Prime   Connectivity Kit
 r14622     r14592
 r14425     r14592
 r14425     r14596
(The revision being the number after 2.1 in the version information.)

I tried both adding definitions to the Solve app itself and a saved copy (a clone) of it.
  • Does the issue you’re experiencing happen even after resetting the Solve app and adding just a single simple equation to it?
  • Can you view definitions in other apps (using the Connectivity Kit)? (Such as the Function app.)

Hi jte,

Thanks. some answers to your questions:

1. The issue happen even if i reset Solver. Say i reset Solver and then i clone it, it will become like a function afterwards.

2. in the connectivity kit, i can see the solver clone app - it appears as a function app and the symbolic tab shows F1 to F0 and no longer E1 to E0 like a solver app.

Why is this happening and how do i prevent this?

Thanks
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: