Post Reply 
[BUG] getting a French error message when using Prime in German language
02-23-2014, 04:45 PM
Post: #1
[BUG] getting a French error message when using Prime in German language
If language is set to german and I enter the following:
$$ \int_0^2 \left( \begin{cases}-2-x & -2 \leq x < -1\\ \sin\left(\frac{\pi}{2} x\right) & -1 \leq x < 1 \\ 2-x & 1 \leq x < 2 \end{cases} \right) \cdot \sin\left(n \pi x \right) \rm{d}x$$

I get the error message in french: "Aucun cas ne s'applique". (English version is: "No case applies")


Btw: I entered the big piecewiese expression first in the plot mode (with capital X). I then copied it to the CAS where I had to replace every capital X with a lowercase x. I tried to do this with "subst()", but this fails because X is intialised to zero. Is there a better way than replacing every X manually to do this?
@HP: Please get rid of this capital/non capital variable crazyness.
Find all posts by this user
Quote this message in a reply
02-23-2014, 05:01 PM
Post: #2
RE: [BUG] getting a French error message when using Prime in German language
It is because only the french were supposed to fail...
Seriously I have most of the error messages in English while I chose French in the settings.
Find all posts by this user
Quote this message in a reply
02-23-2014, 09:55 PM (This post was last modified: 02-23-2014 09:55 PM by Joe Horn.)
Post: #3
RE: [BUG] getting a French error message when using Prime in German language
(02-23-2014 04:45 PM)Stefan Wrote:  ... I then copied it to the CAS where I had to replace every capital X with a lowercase x. I tried to do this with "subst()", but this fails because X is intialised to zero. Is there a better way than replacing every X manually to do this?

Quoting the original and the replacement does the trick. Case-sensitive example in CAS:

subst('X^3+2*X+3','X=x') --> x^3+2*x+3, as desired.
Notice that both arguments of subst are quoted.

<0|ΙΈ|0>
-Joe-
Visit this user's website Find all posts by this user
Quote this message in a reply
02-23-2014, 10:26 PM (This post was last modified: 02-23-2014 10:26 PM by eried.)
Post: #4
RE: [BUG] getting a French error message when using Prime in German language
There is a lot of typos even in the english version.

Just check: http://www.hpmuseum.org/forum/thread-494.html in MS Word. Every couple of lines there is a typo in the help. Now think on the fact that the other languages are probably derived from that english version...
I personally use the device in english because spanish is full of weird abbreviations and bad translations in every single screen.

My website: ried.cl
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: