Post Reply 
Bugs in Solve command.
03-07-2017, 10:32 PM (This post was last modified: 03-07-2017 11:37 PM by Helge Gabert.)
Post: #21
RE: Bugs in Solve command.
It would be nice to make a hardware, firmware update available soon (especially since this, and similar problems involving solving with symbolic variables, worked in some firmware versions prior to 10637).

Interesting, too, that solve(-x-e^x=0,x) with only one variable still results in the error message "Unable to isolate", but solve(-x-e^x=0,x=-.2) works!
Find all posts by this user
Quote this message in a reply
03-07-2017, 11:58 PM (This post was last modified: 03-07-2017 11:59 PM by akmon.)
Post: #22
RE: Bugs in Solve command.
(03-07-2017 02:49 PM)Arno K Wrote:  
(03-07-2017 01:31 PM)akmon Wrote:  Curious, I get the same warning as math7 does "Unable to isolate...", in my physical calculator, with last version and x and a unassigned.

Yes, I get that warning, too, but after "Enter" it provides the correct result.
Arno

Are you a beta tester? How could you get the solution? Is your hardware version 10637?
Find all posts by this user
Quote this message in a reply
03-08-2017, 12:54 AM
Post: #23
RE: Bugs in Solve command.
Ohhh I thought it was me that was wrong but now I see that it is a bug in the CAS and that in the development version yes it is correct, it will wait a little bit then to release already the corrected version and install it, it is good to know it and what Good that exists this forum to be polishing and purifying more and more our HP Prime !!!
And the contributions of all are welcome, I will also go up if I find more errors and hopefully be taken into account in upcoming updates to make the Prime as legendary as the HP 48GX or HP50g.
Find all posts by this user
Quote this message in a reply
03-08-2017, 01:09 AM (This post was last modified: 03-08-2017 01:11 AM by math7.)
Post: #24
RE: Bugs in Solve command.
(03-07-2017 10:32 PM)Helge Gabert Wrote:  It would be nice to make a hardware, firmware update available soon (especially since this, and similar problems involving solving with symbolic variables, worked in some firmware versions prior to 10637).

Interesting, too, that solve(-x-e^x=0,x) with only one variable still results in the error message "Unable to isolate", but solve(-x-e^x=0,x=-.2) works!

I first get a warning when I enter solve (-x -e ^ x = 0, x) but press the ENTER key gives me the correct answer. When entering the value of the approximation -2 for x the First does not give me the warning but it gives me the correct value at one time but not in the format of the list as in the first case. See screenshots.

Note: I did it on the Virtual Calculator on PC with 11226 version.


Attached File(s) Thumbnail(s)
           
Find all posts by this user
Quote this message in a reply
03-08-2017, 08:02 AM
Post: #25
RE: Bugs in Solve command.
(03-07-2017 11:58 PM)akmon Wrote:  
(03-07-2017 02:49 PM)Arno K Wrote:  Yes, I get that warning, too, but after "Enter" it provides the correct result.
Arno

Are you a beta tester? How could you get the solution? Is your hardware version 10637?

I must admit that I used the wrong device to test that, so, yes, it was my other device, sorry. But so you can be sure that this problem is solved in a future release. I will be more careful in the future.
Arno
Find all posts by this user
Quote this message in a reply
03-08-2017, 01:31 PM
Post: #26
RE: Bugs in Solve command.
(03-06-2017 06:53 AM)parisse Wrote:  exact, use sqrt, principal checked
complex, use i unckeched.

And within a program, how do I set these flags?

Hp-prime programming capability seems limited =(
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: