Post Reply 
HP-50G: "LASTARG disabled" ???
09-29-2014, 05:44 PM
Post: #1
HP-50G: "LASTARG disabled" ???
I entered Joe's HP-50G program described in this video; Programming the Same Task: HP-41, HP-71B, HP 50g, HP Prime ... and it keeps failing with an error message "LASTARG Error: LASTARG disabled."

I've looked through the manuals to see if there is some kind of flag that enables/disables LASTARG and have come up blank.

Does anyone know why this isn't working? (Thanks!)
Find all posts by this user
Quote this message in a reply
09-29-2014, 09:36 PM
Post: #2
RE: HP-50G: "LASTARG disabled" ???
I found the answer on this obscure document after a diligent Google search. Search the page for "LASTARG Disabled" and it appears that flag -55 should be clear in order for LASTARG to be enabled.
Find all posts by this user
Quote this message in a reply
09-30-2014, 01:51 AM
Post: #3
RE: HP-50G: "LASTARG disabled" ???
Flag -55 is also mentioned in the entry for LASTARG in the HP 50g Advanced User's Reference Manual.

FWIW, press MODE, F1 (FLAGS), 5. See the entry for flag -55 (the negative sign is assumed). Clicking F3 (CHK) on flag -55 will toggle between "Save last args" and "No last args". Suggestion: Except in temporary extreme circumstances, always leave that flag clear ("Save last args"). If you have a program that sets it, edit the program to clear it before exiting.

<0|ɸ|0>
-Joe-
Visit this user's website Find all posts by this user
Quote this message in a reply
09-30-2014, 02:55 AM
Post: #4
RE: HP-50G: "LASTARG disabled" ???
Thanks Joe! Wink
- Bill
Find all posts by this user
Quote this message in a reply
09-30-2014, 08:47 PM
Post: #5
RE: HP-50G: "LASTARG disabled" ???
Bill,

Just so you know, you can also turn this feature on/off by going to the LeftShiftHold-Mode menu, then selecting MISC. From there you can toggle ARG off and on.

As Joe indicated, there are not too many times you'll ever want to disable it. The only thing I can think of is if you had a REALLY large object and you didn't want it to take up memory sitting in LASTARG.

-wes
Find all posts by this user
Quote this message in a reply
09-30-2014, 10:54 PM
Post: #6
RE: HP-50G: "LASTARG disabled" ???
Thanks Wes! Wink
- Bill
Find all posts by this user
Quote this message in a reply
10-01-2014, 04:06 AM
Post: #7
RE: HP-50G: "LASTARG disabled" ???
(09-30-2014 08:47 PM)Wes Loewer Wrote:  Bill,

Just so you know, you can also turn this feature on/off by going to the LeftShiftHold-Mode menu, then selecting MISC. From there you can toggle ARG off and on.

As Joe indicated, there are not too many times you'll ever want to disable it. The only thing I can think of is if you had a REALLY large object and you didn't want it to take up memory sitting in LASTARG.

-wes

And here's a cute programming tip that most 50g users don't know. When the menu Wes mentioned above is showing, press right-shift ALPHA (ENTRY), then press either left-shift ARG and see -55 SF, or press right-shift ARG and see -55 CF. It types the flag number for you! In general, when you're programming and you forget any flag number (e.g. what flag turns off the beeper?) just go to any menu that has that flag in it, and press left-shift to set that flag, and right-shift to clear it, without needing to remember the flag number.

You might notice that STK and CMD in Wes' menu don't seem to obey this "programming tip". That's because they are not controlled by normal flags, and cannot be turned on and off with the SF or CF commands.

<0|ɸ|0>
-Joe-
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: